Local Community

Duplicator to move to Local from AMMPS. How?

I have a single site on AMPPS that I was going to move to LbF to get closer to the “production server” setup at flywheel.

Does anybody have a step by step guide about how to IMPORT a site from a duplicator archive into LbF. Is that even what I want to do? In this case, do I even create a new wordpress blank site in LbF first, or is there a way to just get LbF to import something (duplicator or some other package) without having to go through all that LfB site making.

I’m not sure what route to take.

Or should I just stick with AMMPS?

You can absolutely move your site into Local with Duplicator.

Like you said, you’ll need to create a new site and then go in and remove all of the new WordPress files. After that, you can bring in the Duplicator archive and import script and go through that routine.

One thing to note: on the database tab an IP is shown for the host. This is for connecting remotely so when you actually import with Duplicator the database host is simply localhost

okay I will get on that.

One more question. If I am working locally on a site named dev.joesite.com and I move it up to the host and want it named marysite.com, willl I have to change all the links in the site or will wordpress take care of that?

You can use Duplicator again for deploying your site and it will take care of it.

We’ll be adding deployment features down the road though :slight_smile:

1 Like

I deleted all the folders in the folder created by the fresh install on LbF that I made (so empty of all subdirectories). Then I copied the new archive and the installer.php file. How do I get the installer.php file to run. I point my browser to it and it show me the code in installer.php.

What is the proper url to make the duplicator installer.php run?

I am trying to do the same, but from MAMP.

If you put the archive.zip and the installer.php file inside your public folder (home/Local Sites/Your Site/App/Public) it should be:

sitename.dev/installer.php

I have duplicator running from the installer, but I am getting a server timeout when trying to copy over the DB, but I will start another forum post for support.

Thanks,

That got me closer.

I have a migration, but I was getting error warnings - ngix.

I need ioncube loaders and don’t feel like blowing another 2 hours getting all them configured (if it is possible)

All in all this certainly was not easy. I don’t have much confidence that my migration is correct and its not working.

I hope the process improves, but I at this point it doesn’t seem much better than the ammps local install that i have working. I’m not a developer so I don’t need to be dealing with multiple sites every week. I think I may wait unit LbF works a fluidly as the advertising seem to indicate it will.

Yeah, that makes sense.

For me, it is a lifesaver. My MAMP set up was slow, due to the whole Bonjour Localhost confliction. I’m also not so much of a developer so trying to configure MAMP Pro to use .dev instead was a bit of a head scratcher.

Local for my use case, is much more user friendly than MAMP. My main issue now is that I can’t use symlinks… but thats for another post.

Good luck