Local Community

"fileinfo module not installed or disabled" warning after updating php

Hello,
After updating php, I received this following warning as I ran a site health check:
Warning The optional module, fileinfo, is not installed, or has been disabled.
What should I do?
Thanks.

1 Like

Hey @alexandramaclennan, Welcome to the Local Community Forums!

I just tried to replicate this on the latest version of Local (5.7.4) and macOS Catalina. I tried updating the site from PHP’s default version of 7.3.5 to 7.4.1 and I’m not able to see that error message.

Can you give a little more detail on where you are seeing this? For example:

  • What version of Local is installed?
  • What operating system is being used? What version of the OS is installed?
  • What version of PHP is being used?

Hi Ben, …

I’ve just had the same issue as Alexandra MacLennan.

OS Win 10
Flywheel - 5.8.2+4949
Latest PHP ver: 7.4.1, (selected the other day because WP was complaining.)

And as stated, I also got the system health warning that reported the ( fileinfo ) error.

Following the advice on the lower link, and adding the DLL extension name to the PHP config file; fixed my WP health warnings issue.

This is here should anyone else in 2020 encounter this error, seems that it happened quite a lot in the past, not so much these days.
I suspect that the PHP 7.4.1 package is incomplete somehow, but I’m no expert.

Hope it helps, stay safe.

1 Like

Same here:

One or more recommended modules are missing

Performance

PHP modules perform most of the tasks on the server that make your site run. Any changes to these must be made by your server administrator.

The WordPress Hosting Team maintains a list of those modules, both recommended and required, in the team handbook (opens in a new tab).

  • Warning The optional module, fileinfo, is not installed, or has been disabled.

Windows 10 Pro, latest Local version, Nginx configuration with PHP version 7.4.1, MySQL 8.0.16, and WordPress 5.5.1. Non multi-site configuration.

I can probably install this easy enough, but should deploy with local as a default given that WordPress is kind of Local’s specialty.

2 Likes

Thanks for all the feedback and helping to make Local better!

I’m getting carving out some time for our devs to work on automating the testing of the Site Health page for all the various OSes and PHP versions Local supports.

1 Like

I am on latest Local, 5.9.3+5100, Windows 10 Pro, PHP 7.3.5

I’m having an issue with trying to get the fileinfo module enabled. For one, it should be enabled by default, and as @stesab92 mentioned, it’s one of the core modules for WordPress functionality.

I’ve followed the advice in the thread @Terry shared, though even that was slightly unclear to figure out where that conf/php/php.ini.hbs file was even located. Presuming I found the correct one in C:\Program Files (x86)\Local\resources\extraResources\lightning-services\php-7.3.5+10\conf, adding that line seems to do nothing as the php.ini file that gets generated into C:\Users\<user>\AppData\Roaming\Local\run\<site>\conf\php when the site is restarted is not reflecting that change. Can anyone help me figure out what I’m doing wrong?

Tagging @clay since he gave the answer in the linked thread.

edit: for those dealing with this later, the php.ini.hbs file to edit is in C:\Users\<user>\Local Sites\<site>\conf\php (presuming you are using the default installation settings). That was more difficult to figure out than it needed to be. @ben.turner could it be passed along that fileinfo should enabled by default in Local?

1 Like

I went in to do some additional testing and tried to replicate this, but I haven’t been able to. It looks like the fileinfo extension was added to the PHP service, but maybe the installation on your machine is using an older version of the PHP service.

The Local team is working towards making updating services easier, but in the meantime, @jonc, can you try updating your PHP services by following this FAQ:

Let me know if that gets the fileinfo module added for newly created sites!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.