Live link inconsistencies

I’m getting a ‘too many connections’ error about every other time i try and navigate to another page when using the live link. I’m thinking of using a free ngrok account but I can’t get that to download. thoughts?

Hi Jack,

Sorry for the trouble!

Live Links in Local are powered by ngrok’s free version by default so you likely won’t notice a change by redownloading ngrok.

One thing you can do is try Ngrok’s premium version to increase that limit for Local. See Is it possible to custom live link? for more details. Note, this will bump your allowed connections per minute from 40 to 60.

To reduce the number of connections, try to limit the number of page requests you make. Also, you may want to try adding a plugin that handles minifying/concatenating your CSS/JS files into a smaller number of files to reduce the number of requests.

Finally, another option is to utilize Connect to Flywheel (and soon to be Connect to WP Engine) and push up the Local site to an online staging site. This way, you don’t have any connection limits and you don’t have to keep Local running for the client to view the site.


With the recent investments in the Local team thanks to the WP Engine acquisition, we’re hoping to have a solution for the Live Link connection limit sometime in 2020.