Local Community

Local 5.x Issues

Hello @clay I would like to leave my 2 cents. I’ve seen great evolution on 5.5.x and most issues solved. I’ve started working on with, found some (new other old) issues:

  • NEW - My page builder (Cornerstone/X/Pro from Themeco) doesn’t work on Local, but it works seamslessly on Local by Flywheel 3.x. I’ve reinstalled 3.x to test and indeed it works. You can contact me in private I can send you a copy of the latest version of these themes (the pagebuilder is a part of them) so you can test yourself.

  • OLD - I still can’t open the DB for any Local WordPress site using Sequel Pro. It starts with a message of “crash on last session”, even when it didn’t happen. Adminer works but Sequel Pro has multiple advantages for DB editors.

  • OLD - I’m not sure why /?cache-buster=whatever is placed after any URL when sites are being loaded from Local (I’m on a Mac with Mojave system).

  • OLD - I’ve been testing Redis Object Cache plugin on WordPress, to discover that Local is now using Predis, wich was abandoned by development. Local by Flywheel 3.x was using PhpRedis, an outdated version but was still much better than Predis.

  • OLD - As related by many, the Update (in-app) doesn’t work on Mac. We’re being forced to download every new version and overwrite on the Apps folder. Indeed it’s keeping sites and preferences, wich is good.

No news about those?

Hey there (@clay, @flyjack)

All the above are stll present on Local 5.6.1 (under MacOS Mojave). Is there any roadmap to fix those issues? Mac users would greatly appreciate.

Thank you and best regards

Hey folks, just to keep the topic open, all the issues related on this post are still there on Local 5.6.2. Adding more resources to the App when some basic things aren’t solved/working, will just keep those issues kinda forever… Maybe it’s time to stop adding and fix those that doesn’t work…? Cheers.

Hi @fabiofava,

Sorry for missing this! I appreciate the clearly-written bullet points :slight_smile:

Can you please send me a copy of this? Alternatively, a site export will work. My e-mail is clay@getflywheel.com.

OLD - I still can’t open the DB for any Local WordPress site using Sequel Pro. It starts with a message of “crash on last session”, even when it didn’t happen. Adminer works but Sequel Pro has multiple advantages for DB editors.

This is a bug with MySQL 8 and Sequel Pro. Either switch to MySQL 5.7 or update Sequel Pro to the nightly that can be downloaded here: https://sequelpro.com/test-builds

OLD - I’m not sure why /?cache-buster=whatever is placed after any URL when sites are being loaded from Local (I’m on a Mac with Mojave system).

Noted. This was added to prevent browser redirects. We may add the option to disable this at some point if there’s enough interest. Feel free to create a feature request here if there isn’t already one: https://feedback.localwp.com/

OLD - I’ve been testing Redis Object Cache plugin on WordPress, to discover that Local is now using Predis, wich was abandoned by development. Local by Flywheel 3.x was using PhpRedis, an outdated version but was still much better than Predis.

This is primarily due to Local not shipping with the PhpRedis extension. We can look into re-adding this if necessary. Again, I recommend creating a feature request here so we can gauge interest and prioritize it: https://feedback.localwp.com/

OLD - As related by many, the Update (in-app) doesn’t work on Mac. We’re being forced to download every new version and overwrite on the Apps folder. Indeed it’s keeping sites and preferences, wich is good.

Interesting! I haven’t seen this for quite some time. I recommend trying the commands here: [macOS] Help! Local isn't automatically updating!

Hey Clay,

I’ve sent you the Themes by e-mail but I got an error, seems like your server has refused.

Please let me know if you have received, otherwise we’ll put it on Dropbox or GDrive (the one you prefer).

Cheers!

Hi Fabio,

Feel free to send over a Dropbox link. Also, make sure you’re emailing me directly at clay@getflywheel.com rather than replying to the Community e-mail notification.

Hi Clay,

I’ve sent using Apple Mail directly, but got the error. I’ve created a Dropbox Transfer to your e-mail address, so you can download them. In case you need to register the themes for testing, just let me know the domains you use and I’ll set them.

Hey @clay

Pro/X Themes - Sent
SequelPro - I’ve donloaded it and it works
CacheBuster - Would love this option, the actual way it creates redirections
PhpRedis - it would be a lovely addition to Local App
Updates are now being done by the App itself (and login is persistent), great!

Cheers!

Hi @clay,

Did you get the Dropbox link for the X/Pro themes?
Please let me know as you’ve downloaded them, so I can delete that folder.

Cheers!

Hello @clay, would you confirm if you’ve got the files so I can delete them from Dropbox?

Hey @clay, just to keep the post open.

Did you check the Themes? Thanks!

Hey there, just to keep up-to-date, as at v 5.6.6:

• Pro/X Themes - still aren’t loading the builder and their interface
• CacheBuster - I’ve created a suggestion, hope it gets implemented
• Updates - couldn’t update from the app to 5.6.6, had to download

Cheers!

Just keeping the topic open. Still can’t edit the pages withe my themes’ page builders. Cache Buster isn’t a serious issue, just very annoying.

Hey @clay

Local 5.6.8 is out and I still can’t load Themeco Page Builders & Backend.

Local 5.6.6 didn’t recognize the new update, had to update manually.

The option to remove Cache Buster would be greatly appreciated.

Cheers!

Hello @clay

Just downloaded Local 5.6.9.

• The App couldn’t find the update, had to do it manually
• I still can’t load Themeco (Pro and X Themes) Page Builders and Backend
• Cache Buster stills on and creating un-needed redirections

Hope this can be fixed (specially the Page Builders), so I can work with Local WP.

Cheers.

I just upgraded to Local 5.6.9. What a pain. It took 24 hours for me to figure out how to get it working. I had to uninstall the previous version, find every file related to Local on my computer and delete them. Then zip the wp-content folders plus their related sql file and import each site individually.

The next issue I’m having is that “Not So” MagicSync isn’t pushing anything from the WP-Content folder to WPEngine. I’ve tried both “only newer files” and “all modified files” but neither work.

What was suppose to be a quick finish of a site scheduled to go live has now delayed everything by a day.

Hey @clay,

After reading @northtexas above, I’ve attempted to completely remove LocalWP and reinstall the 5.6.9 from the scratch. I’ve managed to load Themeco’s Page Builders and Backend. Cache Buster should have an option to get disabled, since it’s redirections are messing up on Multisite installs.

Cheers

1 Like