Local Community

Local by flywheel mailhog not intercepting outgoing emails

My dev environment is Windows 10 Pro, Local 5.5.3+3667, and WordPress 5.4.2, I am having a problem with MailHog not intercepting outgoing emails. After the first install it appeared to be working straight out of the box. It was intercepting the WordPress admin notifications for new administrators and users. I recently upgraded to the latest version of Local and MailHog stopped intercepting emails. One of the sites only intercepts the WordPress admin email notifications, the form emails go off into the ozone but show as being sent without any errors.
Even with a clean install of Local on a different laptop the problem is the same, it doesn’t work. MailHog indicates it connected. After installing a smtp plugin they work, and the email sent and are received bypassing MailHog. From reading about similar problems, MailHog appears to be incompatible with some smtp plugins.
Local has some good features, and MailHog would be one of them if it worked seamlessly.
I’ve checked the configurations, and nothing really stands out as to what may be creating a problem.
Searching for clues on the Internet there are others with the same problem, but there aren’t any solutions that helps them or me. I’m hoping that someone will find a solution and post it. I will continue search for a solution of workaround to the problem.
In the meantime, is there an alternative to MailHog and that functions with other smtp plugins, and if it integrates with Local that would be even better.
Thanks for any insights!

Hello!

This is a known bug that we are actively working on. I will update once we have this fix out and available to folks.

Thanks for the update!

Hey @rjamespreston - the Mailhog bug is fixed in our latest release 5.6.1 Local 5.6.1

I am using FlyWheel version 5.6.2 on Windows 10 (v2004). MailHog does not capture Woocommerce messages, even authorizing MailHog in Windows Security Firewall.

I’ve been dealing with changes to the PHP version and enabling LiveLink, but it has been unsuccessful. Crazy thing is that the emails seem to be there, a ‘flash’ occurs that lasts a fraction of a second, but the ‘stable’ result is a blank page. Zero emails.

(https://drive.google.com/file/d/1OrT62r9O5hcJc-8dlRQJyBnsiOMl6Voe/view?usp=drivesdk)

By the way, I´m using Local 5.6.3+4270 (by upgrade from 5.6.2)
But using Apache server and PHP 7.4 I get the error message: No input file specified.
The local website is gone.

I’m having the same problem. My workaround is to install a mail logging plugin. Or, if I need emails to actually go out, to use live link and set it up on smtp server (I use smtp2go).

Hey guys!

Alright, let’s see… Smtp plugins (like mailgun) can cause issues with Mailhog - if you are using those, can you disable them and try again?

Additionally, can you try hot-swapping to another PHP version and then back and see if that does anything?

Thank-you meeae, swapping PHP version did the trick! I was apparently using 7.35, so I selected 7.41 in the PHP combo box on Overview page of Local. Now Mailhog intercepts the emails. Thanks for figuring that out!

Greetings, I’m using Local to create a test Wordpress site on my Windows 10 computer. I use the WP plugin “Check Email” to send out a test email, but Mailhog doesn’t catch it. So, looking at this forum, I saw that maybe I needed to upgrade to Local 5.6.1, which I did. But, still no luck with Mailhog.

Then, I read that SMTP bypasses Mailhog, and that maybe I could actually send out an email out into the internet? So, I installed various SMTP plugins in WP to help with that, and the SMTP server I’m trying to use is called SMTP2GO, which gives me a SMTP username/password to use, as well as the name of its server, all of which are needed in the SMTP plugins. But, when I try to send an email I keep getting the error that the FROM address is not recognized, even though the URL matches my locally created website (.local)

Does anyone have any helpful insights what I could be doing wrong?
Thanks for reading and for your help.

I also tried going to Windows settings, Security, Firewall, and adding Local as an exception, as I read that was also a possibility. But still no luck with emailing.

When I used the “live link” in Local, and set up that temporary URL with the SMTP server, then I was able to send an email. But I still can’t get regular WP (php) mail to work (or to be collected by Mailhog).

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.