Local doesn't open on Debian

I installed the file local-5-0-6-linux.deb in Debian bullseye with line dpkg -i local-5-0-6-linux.deb but simply it don’t open.

Do you know how I can solve this problem?

Hi! This issue was resolved in another thread, here: Setting up the new lightening in linux mint or ubuntu

Can you try installing with the commands the user “tkhara” used:
sudo dpkg -i ~/Downloads/local-5-0-6-linux.deb
sudo apt-get install -f

And let us know if it works for you? Note: you may need to change the path to the file.

Thank you,
Megan

Hi @mwallace.

I had already read this thread. I did that, but it didn’t solve my problem.

In my case it displays the Local icon, but does not open the App when I click it.

Hi @Rafaelhgb,

Try installing libaio1 and libncurses5, probably using sudo apt-get.

And if that doesn’t work, then try installing try libaio, libXScrnSaver and ncurses-compat-libs.

Thanks!

Hi !
I have the same problem.
Even after following each of the instructions given above and installing the missing packages, local seems to be installed but does not run.
(I’m on Debian Buster)

Hi @42Glider,

Can you please provide the errors you’re seeing when trying to install/run Local?

@clay in my case, just don’t open.

I was never able to open my Local.

Hi, so I just tried to run the binary directly from the terminal and I got this error:

[3684: 0121 / 100422.185090: FATAL: setuid_sandbox_host.cc (157)] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I’m aborting now. You need to make sure that / opt / Local / chrome-sandbox is owned by root and has mode 4755.
[1] 3684 trap / local trace

So I fixed the problem by executing it with:
./local --no-sandbox

The concern seems to be related to the Debian security policy regarding sandboxing. I found this thread that talks about it: https://github.com/tutao/tutanota/issues/1565.
There is a workaround which consists of adding the following command to the /etc/sysctl.conf file:
kernel.unprivileged_userns_clone = 1.

But it doesn’t seem great regarding the security of the kernel.
So I made a sudo chmod 4755 chrome-sandbox in /opt/Local

Everything works perfectly and Local is running properly now! :grin:

1 Like

Awesome, thanks for sharing the solution!

In the meantime, we’ll keep an eye out for a solution on our end that way the workaround isn’t required. :slight_smile:

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.