Local Community

No Extension None of the supported PHP extensions (MySQLi, MySQL, PDO_MySQL) are available

Following. I’ve just downloaded v5.0.7beta as I suffer this issue, but the new version did not solve the issue. Windows 10. This happens with new vanilla sites too.

Hi, same her. I have downloaded v5.0.7beta and nothing changed. Problem with adminer is same.

Ditto, same message on brand new installation, brand new computer, version 5.0.7+1117 on Windows 10 Pro: None of the supported PHP extensions (MySQLi, MySQL, PDO_MySQL) are available.

Same problem on new installation.version 5.0.7+1117
When install new site or pull site from flywheel, cannot open (database connection problem), and when trying adminer same issue as above.
I have no problems running Wordpress in Xampp or IIS, but cannot use Local (and I’m about to start my first project with FlyWheel next week.

I am also facing same error with version 5.0.7+1117 on Windows 10 Pro (64bit)

I was directed by support to try this version:


and here everything works great.

v5.0.7 +1117

same issue: None of the supported PHP extensions (MySQLi, MySQL, PDO_MySQL) are available.

While they manage to solve this bug, you can download Adminer from its official website https://www.adminer.org/ , and include it in the root directory of your project.

Then, you can access your database in http://yourproject.local/adminer.php

The URL may be different depending on which version of Adminer you have downloaded.

For security reasons, remember not to upload that file to your production site.

2 Likes

This works for me, thank you!

1 Like

Hey @victor.bini

This should be coming soon, some more info in this post:
https://localbyflywheel.com/community/t/adminer-no-extension-error/15406/5?u=jkiley

1 Like

Hey @jkiley

Good news, thanks for your effort on this great software

Hey guys, for all who are struggling with adminer, try tableplus instead, it worked for me

follow the instructions here:

and put the details given exactly on the database tab of your site, especially the port and host

if your sql is fine and running this should work in sha Allah

Loving everything else about local <3

1 Like

Hi All,
I have found one solution to open the adminer and view the database
download file adminer file from https://www.adminer.org/#download below is the link for download
https://github.com/vrana/adminer/releases/download/v4.7.5/adminer-4.7.5-en.php

after it is downloaded copy the file and paste inside the
\app\public directory and then open the website url in your browser and a file name which you have copied to the directory
for example https://www.example.com/adminer-4.7.5.php

and then you will see the screen for login so then copy the credientials from the wp-config file and the you can see the database tables easily

Below is the login screen of adminer

This is an alternate solution if adminer for localbyflywheel doesnt work

2 Likes

Just updated today and have this issue. Windows 10. Local 5.2.3.

1 Like

Where is the “Create New Connection” button? Thank you

1 Like

Same here post migration from v3.x.x

1 Like

Getting this error with v5.2.3+2248.
I cannot run v3.3 anymore because it no longer works after running v5. Also, it overwrote my database files in v5, so I lost entire databases. Another HUGE gripe with v5 is that it ONLY EXPORTS/SAVES/READS the local database.

I do NOT use the ‘local’ database. I either ignore it, or delete it altogether. My database is named differently. BUT v5 Won’t Let me use a differently named database.
Worse: after running v5, the ONLY time it loaded and let me run v3 after that, it DELETED My databases upon stopping any site that I could get it to stop for. Or maybe it deleted them when starting the site??
I could not even get it to stop all sites properly.
Eventually I had to force close Local by Flywheel.
In the end, several sites not longer have MY database in their sql directory.
AND Local By Flywheel v3.3 WILL NOT LONGER START…
So I have NO way of accessing those databases even through MySQL Workbench. :anger: :angry: :angry:

I don’t often use Admirner, as I usually use MySQL Workbench instead. But I’m troubled that the Admirner link does not work in Local v5+.

Had the same problem with the new updates (5.2.3, 5.2.4, and now 5.2.5+2498) in Windows 10. I had to use DBeaver instead.

1 Like

Same here with 5.2.5+2498 in Windows 10

This error appears because you dont properly install php module, for ubuntu its:
sudo apt install php7.4-mysql
its required even if you install mariadb already.
After that it will work as a charm