Local Community

Performance issues with Local on Windows 10

When I first installed Local it was pretty quick but now it’s very slow, in the order of 10 or more seconds to load a page!

I just updated to Local 2.2.4 but no change. I have the ‘Faster Docker Volumes’ and ‘IPv6 Loopback’ options enabled but still no difference.

I really like using Local but it’s become unusable for development work as it’s so slow.

1 Like

Yes, I can confirm that I have this problem as well on a Windows 10. My version of Local is the latest one. I have upgraded it today.

1 Like

Same problem, have spent hours trying to fix and have tried many suggestions from various sources on Google. It is not usable for development on windows machine. Need to find out what is causing the bottleneck.

1 Like

Sorry for the slowdown!

I don’t have a specific answer but here are a few things you all can try:

  1. Restart the Local Machine by clicking on the menu icon in the top-left of Local’s window and go to “Restart Local’s Machine”
  2. Turn off “Faster Docker Volumes” and then re-enable it
  3. Restart your computer
  4. Try turning off your WiFi or disconnecting your ethernet cable. This is an easy way to eliminate DNS issues or slow outbound HTTP requests from your Local site.
  5. If the previous steps didn’t help, try using Query Monitor plugin to get a glimpse into possible slow queries, slow requests, slow functions, etc.

Thanks for the suggestions Clay. Unfortunately nothing worked. My local development site is still extremely slow.

I swapped to the latest default WP theme and disabled all plugins apart from Query monitor but still no change. The db query seems pretty quick (0.01s) but the page generation is huge (16.7s). See screenshot of the admin ‘pages’ screen after loading (I only have two pages in the db!) which takes over 16 seconds to generate.

What could possibly be the cause of this?

Also, I can’t do any WordPress updates as I just keep getting a local route error page show when an update attempt is made.

1 Like

Very keen to find out some solutions here too, agonisingly slow for me.

Clay, is there anything else we can try?

I too am struggling with very slow performance on Windows 10, and also get a local router error when I try to update my Wordpress version.

As a follow-up to this, yesterday all my local sites started to run very fast again for no apparent reason! Even with the Query Monitor plugin running all pages load in under a second, some of them significantly so.

But, I’ve no idea why my local sites were running extremely slow under Windows 10 in the first place, or why they are suddenly fast again. Could they start running slow again without warning?

It would be very useful to have more tools to be able to diagnose problems. In my case the Query Monitor plugin was useful as it showed DB queries were running very fast so it didn’t appear to be a querying issue. But the page generation was huge. Sometimes a page was taking 15-20s to generate and render. I don’t know why this was.

@dgwyer,

Sorry for not responding sooner! I’m glad to hear that performance is better.

Did you restart your computer or the VM in Local? Are there any programs that were running when it was slow that you aren’t running now?

@clay I restarted both my computer and the VM in Local while it was still slow and it did not seem to change anything. And I’m not running any other programs/processes that I wasn’t running before when it suddenly sped up. Very strange. I just hope it doesn’t slow down again!

1 Like

Any solutions to this? Running windows 10 latest version.

1 Like

Kevin,

Have you enabled Faster Docker Volumes in Preferences » Advanced?

If so, please make sure your internet security or firewall (if installed) isn’t blocking it.

Hi Clay,
Yes I enabled the faster docker volumes. There is not firewall of some sort enabled.

@AlwaysQuads,

Got it.

If you go back to Preferences » Advanced, is it still enabled?

Hi Clay,

yes its still enabled.

I am having the above issue and none on windows 10 also . Pretty disappointing that nobody seems to be able to rectify a major fault.

It took 5 minutes to change theme and navigating between pages takes nearly a minute.

1 Like

@AlwaysQuads,

Thanks for the screenshot!


@mikewadewebdesign @AlwaysQuads,

Depending on your setups, the information here may be useful: Slow on Windows 10

Clay, you are a genius - that article helped massively, it turns out Avast was causing the issue! (first part of the topic!)

1 Like

@mikewadewebdesign,

Great, I’m glad to hear @Iws’s solution worked! :smiley: