Local Community

PHP 7.4.1 package missing zlib extensions [macOS & Linux]

Hi,

I was very excited to try out Local on Linux…but I’m now trying to install plugins and it gives me this:

Unpacking the package…
Abort class-pclzip.php : 
Missing zlib extensions
1 Like

I was just bitten by this too, but on Catalina. I believe it is specific to the PHP 7.4.1 package as it works fine on the PHP 7.3.5 package.

Ping @clay

For reference I see this error when trying to update a plugin whose download package is from a Bitbucket release asset.

FWIW, this does work on a server running PHP 7.4.2

Yeah, I want to use the latest version as much as possible for my builds. Have you found a way to solved this?

No solution at this time. I believe it will take a new PHP 7.4 package.

1 Like

Just was bitten by this as well.
Most plugins install just fine with Local / PHP 7.4.1, but some (like themer-pro-1.3.2) stubbornly refuse to.
Using Local and PHP 7.3.x, the plugin installs without problems.
Same with MAMP Pro / PHP 7.4.2: no problem installing the plugin.

The fascinating thing is: this might be due to some combination of PHP package and the ZIP file itself, because installing the previous version of the same plugin (themer-pro-1.2) is no problem on the same Local / PHP 7.4.1 instance.

Screenshot 2020-02-26 at 08.46.51 Screenshot 2020-02-26 at 09.10.16 Screenshot 2020-02-26 at 08.59.10 Screenshot 2020-02-26 at 08.46.22

@clay is it possible to get this fixed in the next beta?

1 Like

Actually, since this is one of the three Local bugs I keep stifling over, I’d vote for @clay to fix this in the next public version :grin:

(Just had to go into Local sites and manually delete the .maintenance due to zlib-aborted Plugin updates file twice in the last hour.)

1 Like

OK, this bug is beginning to really annoy me.

Because an import didn’t work, complaining about missing zlib…

… I thought I’d simply export the site, delete and re-import, using PHP 7.3.5.
Well, doesn’t work, there’s PHP errors and unfixable “URL Settings do not match the host set in Local” warning.

I really hope @clay will look into this soon.

1 Like

I just ran into this problem too. Any movement on this?

This has been reported months ago, and still not fixed in the latest version.

Hi all,

So sorry that this one slipped under the radar.

I’ve added this issue to our team board to look into.

If you all have theme/plugin zips that we can use to reliably reproduce the issue, we’d greatly appreciate it!

2 Likes

Hey @clay. I can reliably produce this error when using my GitHub Updater plugin and updating/reinstalling a package from a Bitbucket release asset.

If you wish to test the test plugin I use is at https://bitbucket.org/afragen/test-bitbucket-ra

2 Likes

I ran into the same error when trying to update Advanced Forms Pro plugin from 1.6.8 to 1.6.9.
When I changed the PHP from 7.4.1 to 7.3.5 updated without problem.

1 Like

Just wanting to add my vote to this issue being fixed. It’s frustrating to be developing with old versions because the new ones are not supported, to then push to staging/live environments and have to upgrade there and re-test everything.

FYI I’m seeing this with the Stripe Payments plugin.

Is there any ETA on this fix?

1 Like

I’m running into the same error, can we get this fixed soon please?

1 Like

For me, downgrading to 7.3.5 was a great workaround for the time-being. Just glad to have it working…

1 Like

Please vote up this feature request. https://localwp.canny.io/feature-requests/p/update-lightning-services-in-app

I am also having the same error… Please fix it soon

Dear Team ,
While changing the Theme of my new website it is not allowing me to change .My new theme installation is getting failed,due to the PHP missing zlip extensions error.Please suggest how to over come this issue.