Local Community

PHP 7.4.1 package missing zlib extensions [macOS & Linux]

Just wanting to add my vote to this issue being fixed. It’s frustrating to be developing with old versions because the new ones are not supported, to then push to staging/live environments and have to upgrade there and re-test everything.

FYI I’m seeing this with the Stripe Payments plugin.

Is there any ETA on this fix?


I’m running into the same error, can we get this fixed soon please?

1 Like

For me, downgrading to 7.3.5 was a great workaround for the time-being. Just glad to have it working…

1 Like

Please vote up this feature request. https://localwp.canny.io/feature-requests/p/update-lightning-services-in-app

1 Like

I am also having the same error… Please fix it soon

Dear Team ,
While changing the Theme of my new website it is not allowing me to change .My new theme installation is getting failed,due to the PHP missing zlip extensions error.Please suggest how to over come this issue.

Hi, Everytime i install any plugin, update any plugin or even hen updating wordpress this error comes Update Failed: Abort class-pclzip.php : Missing zlib extensions Please help me!

what did you really do man…
am still stuck

the same problem with me, what i can do?

Use PHP 7.3.x. The zlib extensions seem to be there.

Hi all,

This is now on my schedule and I’m currently looking into this.

My initial findings:

  • zlib appears to be present for PHP 7.4.1 on Windows, but not macOS or Linux.

What’s odd is I’m not able to reproduce the issue with GitHub Updater, @afragen. It was able to install the plugin on Bitbucket you provided. I initially thought that it might be working on my device due to me having zlib installed via Homebrew, so I went ahead and uninstalled it. However, that didn’t help.

My next step will be to look into our compilation pipeline for PHP 7.4 and see why zlib isn’t showing in phpinfo() for PHP 7.4.1.

I’ll do my best to keep to provide updates here!


We only compiled PHP 7.4 with the --with-zlib-dir flag. We should also be compiling it with --with-zlib.

I’ll get that fixed up and try to get it pushed out to the Lightning service downloader tomorrow. When it’s available, I’ll post here.

Thanks for everyone’s patience regarding this!

@clay, once the plugin was installed were you able to use the branch switching to reinstall it?

Aha. Yup!

I can confirm that the devised fix resolves the issue :smiley:

I’m working on getting the fix packaged up and pushed to our CDN now.


While you’re updating the PHP packages I would hope:suggest that all of them include all the WordPress required extensions.


Awesome, thanks for suggesting this! Since we’re already going through the review/upload process I can’t get these in this moment but I’ll make a note for our team to check all of our PHP versions against this and fix it where possible.

For the sake of prioritization, are there any other missing extensions like zlib that are blocking you from development?

I would recommend ensuring all the image related extensions are included as a priority.

1 Like

Good news! PHP 7.4.1 for macOS has been updated on our CDN.

Due to the lack of a Lightning Services auto-updater at the moment (be on the lookout for improvements here soon), a manual update of the PHP 7.4.1 Lightning Service will be required.

Here are the steps (macOS only):

Update: I’ve copied this into an FAQ: How can I manually update downloadable Lightning Services?

  1. Quit Local if it’s running

  2. Open Terminal and run the following:

    rm -rf ~/Library/Application\ Support/Local/lightning-services/php-7.4*

    If you wish to do this manually, navigate to ~/Library/Application Support/Local/lightning-services in Finder and delete any PHP 7.4 folders you see.

  3. Re-open Local

  4. Add a new site that uses PHP 7.4

  5. Start any existing sites that are using PHP 7.4. Note: Without step #4, you will see errors when the sites are started.

    The next Local update will contain a check for missing Lightning Services and eliminate the need for step #4.


Confirmed working. Thanks @clay


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.