Local Community

Some Genesis Pro Blocks cover sticky header when scrolling down a page

Using Local by Flyweel, and self-hosted sites, but not the WP Engine Dev site, some Genesis Pro Blocks appear over the sticky header. Other content disappears under the header as you’d expect.

This happens with Layouts, Advanced Columns and Cover Blocks.

Maybe a z-Index attribute? Still looking! Thanks for any help.

Cover Layout Covers Sticky Header

It’s the Z-Index setting in one or more of these classes: .gb-block-layout-column-inner, .gb-layout-column-wrap>.gb-block-layout-column-inner, .gb-has-background-dim>*

Not sure the best way to stop content from scrolling over my header, but there’s the cause.

WP Engine created a support ticket. I’ve fixed it for now with this CSS:

.gb-layout-column-wrap {
z-index: 0;
}

I wonder if there’s is or should be a setting for turning Parallax on and off.