Local Community

SSL Not Remaining Trusted

I’m running Windows 10 and Local (Lightning) v5.2.3+2248.

For all my sites the same issue is occurring. I go to the SSL tab in Local and click on the Trust link to the right of the Certificate. It successfully trusts with the checkmark and the graying out of the Trust link. I then go to another tab, say Overview, and then go back to the SSL tab, now the Trust link is again green and the Certificate is not trusted.

If I try to trust a few times in a row, then the Heads Up notification shows up above the tabs and it also contains a Trust link. If I try to trust from that link it tries to do trust but after clicking it nothing happens or changes.

The Heads-Up! message is: Your site is using HTTPS but the Local SSL certificate isn’t trusted.

Tried running Local as admin and that didn’t fix it.

Help appreciated!

I did some further testing and when I try to trust when I’ve opened Local as a non-admin, it doesn’t seem to hold the trust. When I close Local and then re-open as an admin then the Trust still shows as green and not trusted, but somehow the lock works in Chrome and the SSL is now trusted. I can then close Local and re-open as non-admin and the https holds up, so the certs are being trusted, but it’s a bit of a glitchy process to get them to be trusted. I think this is actually a bug, but it’s difficult to reproduce.

One thing, I have Open SSL v1.1.0 L installed (was trying to get localhost certified for https) and I noticed that Local uses Open SSL v1.1.1 b. Could there be some kind of conflict?

One final thing, the https works in Chrome, but not Firefox. In Firefox I get this error code: MOZILLA_PKIX_ERROR_SELF_SIGNED_CERT. Any way to get the green lock icon and https to be trusted in Firefox as well as Chrome?

I have the same issue. I have to enable SSL every time I launch Local, then I get a heads up message but as long as I restart my browser all is being displayed correctly. It’s just super annoying. Tested on Chrome and Edge (Chromuim), admin / non-admin Local launch. It’s as if the information wasn’t saved for W10

Interesting! For me the SSL does remain trusted in Chrome, it does not work in Firefox at all. I don’t have to close Chrome to get the SSL to work, once it’s trusted it remains trusted. Doesn’t matter if I close Local and re-open it, the SSL remains trusted in Chrome. But Local is showing that all the certs for my sites are NOT trusted, so there’s clearly an SSL bug in Local.

So actually I tested it again, and you’re right it remains trusted. So it points to a conclusion that this is a UX bug.

  • When I open Local, next to my Certificate in SSL tab I see Green Link saying TRUST
  • If I click it, it says that my site is Trusted BUT 5 seconds after I get the Heads Up message
  • If I then restart Local, Green Link is back as if it was never pressed BUT site is being displayed fine. As long as I don’t press it I don’t get the Heads Up message :wink:

I’m running Local v5.2.5 now, and I’m on my other work computer, also Windows 10 OS. Getting a slightly different SSL issue now. I imported a website and in the SSL panel I trusted my site, it created a certificate named gutenberg.local. I then imported another website and trusted it as well. Except this website now has the gutenberg.local SSL showing up in Chrome and Firefox, as if Local created a single SSL cert based off the first website I created, then used that same SSL for all additional websites. This clearly doesn’t work as the details are wrong and so browsers are saying the SSL is no good. Clearly there are some major issues with the new Local Lightning. It’s so much faster, which is great, but I’m seeing major issues with SSL certs, with importing and exporting websites because of MySQL v8+ and other issues as well. I love the speed, but I’m almost tempted to go back to the old version as it at least had most major bugs worked out.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.