Local Community

Too Many Connections Error - another ERR_NGROK_702 post

I realized this is an error with NGROK, however is there a plan and a timeframe for a resolution? This was a highly desired feature for me in building client websites. Clients should be able to see progress live. I switched from creating staging subdomains to Local because this feature existed and Local seemed to create an easier solution than FTP and creating a live site on a subdomain.

Is this feature available in a functional capacity in Local Pro? It’s not functional on the standard version. I realize it’s resource heavy for a free version, however, I don’t see any draw to Local Pro if this is not a main feature of the new product.

Hey @nrm

Right now the tunnel provider (ngrok) has a limit of the number of connections or resources loaded in a given time. So, if you have a page with a lot of links to images, stylesheets, or scripts, you can go through the limit quickly.

Improving Live Links is something that we are wanting to do and are still working through the best way of going about this, but there are a number of challenges that have presented themselves in the process.

In the meantime, you have a couple of options:

  • Make use of a plugin to minify and/or lazy load assets so that the total number of assets is reduced for the various pages. Autoptimize should help with this or a more advanced caching plugin like WP Rocket would also help.

  • Deploy a version of the site to a Demo site so that there aren’t any limits on the number of assets that are downloaded

Same problem here. I’m trying to use physical phones and tablets to check the appearance and responsiveness of my sites, but I can only load about one page a minute.

Ngrok is limiting me to 20 connections per minute. But even their paid solutions limit you to 60. A few page loads and I’m over 100…

Deploying to a demo site almost defeats the purpose of having a local development site. Then you’re making changes to the demo site and syncing them back to the local site, or vice versa. Don’t want to go there!

For my purposes, I don’t really need ngrok.io. Just accessing the site through the local network would do the job.

1 Like

You can do that via the latest local by changing the domain from Pretty Links to Localhost in Local’s settings and change the WordPress URL in WP Settings to Computer’s IP.

Thanks for the advice. I tried this but I’m getting a 404 error from Local when I enter the host computer’s IP in the browser of my iPad. Should I be entering something else?

Here’s what I did:

  1. In Local I changed the site domain to “localhost”
  2. In the site I changed the WordPress URL to my computer’s IP

Set Local > Preferences > Advanced > Router Mode to localhost.

Update the Site URL in the WordPress General Settings to your Computer’s IP Address

https://localbyflywheel.com/community/t/ngrok-live-link-too-many-connections-and-multi-device-sync/13546/9?u=louisefindlay23

1 Like

Okay, got it working. It took a little while to clear the caches.

Also, you can’t use https with localhost in Local, so the site URL needs to be something like “http://192.168.1.2:10005”. To get to the site in Chrome on the local host itself, the address is just the same (i.e., not “http://localhost…” but “http://192.168…”). Actually, on my setup Firefox seems to be okay with “localhost:10005” but Chrome is not.

Thanks. I’ll keep playing with this. It’s actually kind of cool.

1 Like

Yeah, it’s a bit complex and I believe you’d have to change the URL back when exporting the site to a different machine but I love it. I can make small changes on my iPad now.

Same problem here. This sucks. The more I use Local and Flywheel, the more reasons I find not to use it and go somewhere else…

Here’s a straight how-to on Louise’s solution for serving Local sites to other devices on your subnet.

1 Like