Local Community

Upgrading to PHP 7.4.1 failed - site cannot be started

I’m developing locally and thought I would upgrade PHP from 7.3.5 to 7.4.1 from the local dashboard. During the upgrade there was suddenly an error message saying that it could not make the php swap.

Now I cannot start my site and in the dashboard the Web server, PHP version and WP version keep on trying to find out the right versions. When trying to start the site I get this error message:
Uh-oh

I also tried to upgrade local to the latest version, but no help there. Please, anyone with an idea of what to do, suggest what could help.
Thanks!

1 Like

I have the same problem with my site. This happened after update Local.

I have the same problem.

I have the some issue. Using Ubuntu 20.04. Cannot create or upgrade a site using php 7.4.1. Works OK on my Windows PC if that helps troubleshoot.

1 Like

Same issue here and now cannot get environment running so no way to export. Stuck.

+1 Anyone from the Local team to help us, please?

+1 Same problem. Stuck, please—need a solution ASAP.

Screen Shot 2020-07-25 at 1.13.03 PM

Same thing happened to me, the only way I was able to get my site working again was to create a new site, import the db and then replace the files…

It sounds like there are multiple related issues here. To clarify the Linux issue, on Linux this is the error I see when attempting to create or upgrade a site to PHP v7.4.1 using Local v5.6.9+4617. PHP 7.3 works good. I’m on Pop!_OS 20.04 LTS.

Screenshot from 2020-08-12 08-21-50

I have the same issue. The good news is that, for me at least, I am able to switch back to 7.3 without issue. There is obviously some kind of problem with the update. I get the same error as @austinginder when trying to create a new site with 7.4. When I try switching an existing site I don’t see an error but the site doesn’t load and the “WordPress Version” line shows that it is refreshing indefinitely. I tried installing some additional development packages related to glibc hoping that it might fix the installation of php74 but it didn’t work.

Unfortunately, I’m dealing with the exact same problem reported by austinginder.
Working on Ubuntu 20.04, Local 5.7.5+4909
I will continue with PHP 7.3.5 guessing no major harm will come with it, though WordPress site health recommendations on minimal PHP state version 7.4
I’m sure we all would appreciate some guidance, even with some “manual tweaking” involved.
( already followed MacOS related post regarding Lightning resources update )