Local Community

Where to update upload_max_filesize? No /conf/ directory found

I’m trying to increase the upload filesize for a site on Local, and I can’t find where the php.ini is setup to handle this.

I’ve already updated the php.ini in my /etc folder, but that wasn’t the one the site was pulling from anyways and it had no effect.

My phpinfo for the site says the path is /conf/php/5.6.20/php.ini

The site is using the “preferred” install.

I can’t find this /conf/ directory anywhere on my machine related to Local (I can find it for MAMP and XAMPP just fine using locate in my command line). Can someone point me in the right direction?

The /conf directory isn’t exposed with the “Preferred” environment. You can still edit it by right-clicking on the site in the Local sidebar then going to “Open Site SSH”.

Once you see the Terminal, you can use nano /conf/php/5.6.20/php.ini to edit the config file. After editing it, restart the site in Local so the changes take effect.


If you wish to have access to the conf directory like you do the app directory, you can use the “Custom” environment. To switch from “Preferred” to “Custom”, you can export the site then re-import it using the “Custom” environment.

Thanks for the info, Clay, I’m sure this will be helpful to others too.

New problem - the php.ini file I can access via SSH declares that the upload_max_filesize = 300M but inside my site’s media loader, my uploads are limited to 1M. What the heck?

I edited the file to use 500M and saved, restarted the local server, but still the same:

I just tested this without any plugins/themes and I’m showing 300M.

Does this site have any plugins/themes or is it fresh? If it’s not fresh, can you try deactivating the themes/plugins and then see if the issue persists?

Hi Clay - Thanks for your efforts here. I’ve fixed my issue, but I’m embarrassed I didn’t figure it out before posting - I’m on a small multisite network, so the 1MB was coming from the network settings. However, I did learn about the SSH options and I also exported and re-imported the site to use Apache so it was a great learning experience for how Local works. Hopefully others will learn from my mistakes!

Glad to hear—thanks for sharing! :smiley: