Local Community

Can't Activate Local Pro

Hello, I just purchased the Local Pro subscription and when I select “Activate Local Pro” nothing happens… it opens Local, but it still acts like it’s in “free” mode. On top of that, I don’t have the ability to submit support requests through the program apparently because it thinks I’m not a Pro subscriber.

Anybody? Help please! Thanks

I’m running Windows 10, just FYI…

Can ANYONE help me? Did I just waste $200?

I have the same issue. Did you get it working?

Furthermore - it is very frustrating that there is not a way to get direct support for this because unless pro is activated, I can’t submit a support ticket because the only way to do that is from the Local app - which isn’t activated so I cannot submit a ticket.

When I click on Activate Local Pro (from my local hub home page), Local opens, then it opens a window in my web browser to login to local hub. I login, click Activate Local Pro and the same thing happens. Over and over and over.

Someone from Local, please help.

Hey @FunkiNATEr and @chrismalone

I took a look and I do see that the subscription is correct within Local Hub. Can you describe in a little more detail what isn’t working? Are you able to use Live Links or the Link Checker tool?

To be clear, right now the two Pro features that have been shipped are “Live Links Pro” and the “Link Checker” tool.

The “Live Reload” tool will be shipping soon (released to beta maybe today, and to stable sometime next week)

We’re aiming to have the “Image Optimizer” tool ready sometime mid September.

Here is a screen record of what I mean that I cannot activate local pro.

1 Like

https://share.getcloudapp.com/YEuovnkR

Here is a screen recording showing what I mean that I cannot activate Local Pro.

Thanks for that screencast – it definitely looks like something is wrong with the login process. What version of Local is installed? Can you try manually installing the latest version of Local here:

5.6.9+4617.
Just to cover all the bases I have downloaded again from the link you sent. It still behaves the same way.

You can consider this closed. I’m just going to request a refund for now. Thanks for trying.

I am having the same issue. Purchased Pro yesterday and cannot activate it. Local opens, but my Pro Plan credentials do not appear. I have the same issue in the video that was posted earlier in this string. I have uninstalled, reinstalled, upgraded to the latest version and still cannot activate Pro. Anyone else experiencing this issue?

Hey @dcgebert, welcome to the forums!

Can you give a little more detail about your setup of Local?

  • What version of Local are you using?
  • What Operating System and OS version is being used?
  • Can you please provide your Local Log? See this Community Forum post for instructions on how to do so:

Hello, I am using the most recent version of Local on Windows 10 Pro. I have uninstalled, reinstalled, turned off Norton 360 and tried (this did not work). I have provided a log to support. Other than telling me to try by turning off Norton 360, they have not responded with any other suggestions. I have turned on all my sites to live (I only have 4 sites up on Local) and clicked the Activate Local Pro and nothing happened. I have attached a local log. At this point, like the other individual on this string, I am about to call it a day and ask for a refund.

local-lightning.log (33.8 KB)

Hey @dcgebert

I wonder if the “Activate Pro” button within Local Hib isn’t communicating back to Local correctly. Can you try clicking the “Login to Pro” button from within Local?

For reference, here’s a screenshot to help visualize where to look:

This was the issue. Support just emailed and advised to log in from the Local app. My Pro account functionality was added when I did this. Thanks for your feedback and help. I am sure that someone else may find this resolution helpful.

1 Like