Local Community

Can't start an imported apache site (or any apache site, actually)

I’ve just installed Local, following the WPEngine Summit 2020.

Local version: 5.5.3
OS: Windows 10

I have created 2 blank sites, using the default settings (nginx, php 7+), and one using apache, and they both work.

However, my imported site gives me the following error: No input file specified.

How do I troubleshoot that?

If I try to change the settings to downgrade PHP, I get the following error:

{"thread":"main","class":"","stack":"Error: Command failed: \"%%userDataPath%%\\lightning-services\\php-5.6.39+8\\bin\\win64\\php.exe\" \"%%resourcesPath%%\\bin\\wp-cli\\wp-cli.phar\" --path=\"E:\\wamp64\\www\\pathway\\app\\public\" --require=\"%%resourcesPath%%\\bin\\wp-cli\\local-wpcli-error-reporting.php\" \"rewrite\" \"flush\" --hard\nError: There has been a critical error on your website.Learn more about debugging in WordPress. There has been a critical error on your website.\n\n    at ChildProcess.exithandler (child_process.js:308:12)\n    at ChildProcess.emit (events.js:203:13)\n    at ChildProcess.EventEmitter.emit (domain.js:476:20)\n    at maybeClose (internal/child_process.js:1021:16)\n    at Process.ChildProcess._handle.onexit (internal/child_process.js:283:5)","level":"error","message":"Unable to swap services site.","timestamp":"2020-06-11T16:33:03.692Z"}

and Local is “stuck” on “Starting Up Site Services”.

ETA: and now if I restart Local, I can’t start the imported site at all, or change the engine or php version:

{"thread":"main","class":"","stack":"TypeError: Cannot read property 'configPath' of null\n    at ApacheService.get configVariables [as configVariables] (%%userDataPath%%\\lightning-services\\apache-2.4.43+6\\lib\\ApacheService.js:90:54)\n    at exports.default.<anonymous> (%%appPath%%\\main\\sites\\ConfigTemplatesService.js:1:1498)\n    at Generator.next (<anonymous>)\n    at %%appPath%%\\main\\sites\\ConfigTemplatesService.js:1:322\n    at new Promise (<anonymous>)\n    at e (%%appPath%%\\main\\sites\\ConfigTemplatesService.js:1:67)\n    at exports.default.compileServiceConfigs (%%appPath%%\\main\\sites\\ConfigTemplatesService.js:1:1282)\n    at exports.default.<anonymous> (%%appPath%%\\main\\sites\\SiteProcessManagerService.js:1:1978)\n    at Generator.next (<anonymous>)\n    at n (%%appPath%%\\main\\sites\\SiteProcessManagerService.js:1:124)","level":"error","message":"Unable to start site.","timestamp":"2020-06-11T16:40:36.200Z"}

I have now also tried to create a new site every permutation of Apache + the different PHP versions and the different DB options.

Apache + PHP 5.6.39 + MariaDB was the only configuration that worked, out of the box.
Apache + PHP 5.6.39 + any of the MySQLs gave me an Index/ directory page showing the wp files, but didn’t actually serve them properly.

Apache + 7.4.1/7.3.5 + any of the database options all give me the No input file specified. error.