Local Community

Local won't open after updating via auto-updater [Windows]

Same issue as well after the last few times updating. This time instead of uninstalling I re-installed and is now working.

Same issue. After auto-update Local does not run. I downloaded version 5.3.3 from website and installed. Now it works again. No data is lost.

1 Like

Hi all,

Sorry for the trouble after updating! We’re currently only seeing this on Windows and we’re actively looking into the root cause.

If this happens, here’s what you can try:

  1. Restart your PC, there may be a lingering process preventing Local from opening again

  2. Re-install Local by downloading the latest version in the Releases category.

    Note: uninstalling can cause your sites list to be removed so be sure to simply download and run the installer for the latest versions.

I just added the following bug to our bug board for tracking’s sake: https://feedback.localwp.com/bug-reports/p/in-some-cases-local-wont-open-after-auto-updating-on-windows

If you have ran into this issue, please upvote it!

I had the same issue and this solved it for me! Thanks!

1 Like

I uninstall and reinstalled, my site was still there. I only have 1 state in the new Local. This worked for me.

1 Like

I did a system restore (windows) , then a fresh download of my Local version (5.4.1). This worked, my site wasn’t deleted but l lost my work back to my last backup a few days ago. I also had to reinstall a few plugins to get them going again.

Thanks Royrogers. Yeah, I figured that one out. But, I appreciate it.

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.

Just updated to Local 5.4.1 on windows 10 and it wont start anymore…

Have you not tested anything on Windows10?

1 Like

I got it working again after downloading the release manually, and just run it as admin.

The update via the program itself failed.

1 Like

Is there any long-term solution for this in the works? I’m getting a little tired of paying $20/month for a program that requires a full uninstall and reinstall every time an update gets pushed out… This is at least the third time that I’ve had this same update issue.

Hi Jeff,

So sorry for the trouble! We’re absolutely going to create a fix for this as soon as we can reliably reproduce the issue.

When you update Local, do you usually do it after launching Local or do you also start up sites and then Quit & Install at a later time?

Hi all, sorry for the back-to-back replies. We were able to successfully reproduce this issue and we’re seeing the Failed to deserialize the V8 snapshot blob. This can mean that the snapshot blob file is corrupted or missing. error pointed out by @AHegge.

We’ve escalated this issue and are working on a fix ASAP.

One quick note, due to the nature of this problem, the actual benefits of the fix will show up after updating to the fixed version meaning this manual reinstallation may be required again.

Sorry for the trouble, everyone!

1 Like

Hi again, Local 5.4.2 is now available and includes a fix for this Windows auto-updater issue in its installer.

Please let us know if this update helps!

Having the same issue updating to 5.4.2.

Thanks for the heads-up!

If you restart your PC and then run the installer, does Local update properly?

1 Like

Once I downloaded and ran the installer again it does.

1 Like