Local Community

No input file specified using PHP 7.3.5 or 7.4.1 ... 5.6.39 works

Yes local is installed on my C drive and the website files are on drive D. So this is totaly the case for me

Do you have any other tool in the mix – for example, is Dropbox, or another file syncing service running on the D:\\ drive?

I’m not using any file syncing services on my D:\ drive. And I’m not sure this feels like a feature request, isn’t this a bug? I can save and open files from any drive in my computer with all the other apps I use without problems…

I use Google Drive and OneDrive sync, but they are not running most of the time and only when I start them manually once a week

Same case here, Win is installed on C drive while local sites are on D, no Dropbox folder or similar tho.

Web Server Apache PHP 7.4, MySQL 5.7. It was a fresh install on a new machine same error. Nginx is working fine.

Hi @ben.turner,

when you allow users to choose a folder for all sites or each site separately and it works in combination of Nginx and PHP 7.3 but it doesn’t in combination of Apache and PHP 7.3 it is a definitely a bug not a feature…

I am on Windows, I do not use Dropbox and I store Sites on different partition than operating system. I use SpiderOak for data backup, however Sites folder is excluded from monitoring and sync.

  • Nginx and PHP 7.3 on different partition than operating system works
  • Apache and PHP 7.3 on different partition than operating system doesn’t work

php 5.6.39 not work - have same message: No input file specified

php 7 sites - works

i use standart folder (in user home directory)

Thanks everyone for helping zero in on how to replicate the issue. That goes a long way towards being able to find the issue, let alone solve it!

I’ve created an issue for our devs to look into though I don’t have a specific ETA for when it will be worked.

I’m sorry for being unclear – I didn’t mean to imply that the way things are is a good thing. What I was trying to communicate was that having the sites on a different partition is a use case that we haven’t accounted for so it might mean additional, new features need to be added to Local in order to get it to work.

1 Like

I am happy to hear that.
I was awaiting this “missing use case” for a long time and would appreciate ETA whenever it will be agreed. Thanks.

i am use windows 7

php 5.6.39 not work - have same message: “No input file specified”
php 7 sites - works ok
use standart folder (in user home directory)

i am use standart creating sites or import from zip, whatever

but on windows 10 all php versions work fine

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.