Local Community

Sites wont launch since updating to Mac Big Sur

I just updated to Big Sur on my Mac and now several sites will not launch, only one out of a dozen. When I click to start the site it gives me a 502 Bad Gateway, and where the wordpress version is listed it never populates. Please help, I have several sites I am working on and in big trouble right now.

Did you find a solution? I just updated to BigSur, the latest version of Local, and there are no other specific errors, impossible to access the site through SSH.

Update: I found out that it only crashes when PHP 7.4.1 is selected; it works with 7.3.5.

It only works with new WordPress installs, not with the old one. Everytime, the error I can find in the logs is this.

Process: php-fpm [14607]
Path: /Users/USER/Library/Application Support/Local/*/php-fpm
Identifier: php-fpm
Version: 0
Code Type: X86-64 (Native)
Parent Process: Local [14564]
Responsible: Local [14564]
User ID: 501

Date/Time: 2020-12-07 08:01:26.025 +0900
OS Version: macOS 11.0.1 (20B50)
Report Version: 12
Bridge OS Version: 5.0.1 (18P2561)
Anonymous UUID: 0F27BD23-A5AC-6B77-D0DB-49F10030A65A

Time Awake Since Boot: 54000 seconds

System Integrity Protection: enabled

Crashed Thread: 0

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Termination Reason: DYLD, [0x4] Symbol missing

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Symbol not found: _udat_patternCharToDateFormatField
Referenced from: /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
Expected in: /Users/USER/Library/Application Support/Local/*/libicucore.A.dylib
in /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation

I found when I changed my sites to 7.3.5 on my old sites it started working again.

Hey @squarepixel and @TigrouMeow – Yeah Big Sur has a couple of issues that we know about:

  1. Open site shell doesn’t work. The Local team is working on a fix, but the current workaround is outlined in this topic within the forums: Open Site Shell not working macOS Big Sur

  2. The PHP service is broken and needs an update. The Local team is working on a better way of updating the PHP service, but in the meantime, you should be able to fix PHP 7.4.1 by following the steps in this FAQ: How can I manually update downloadable Lightning Services?

Hope that helps get you squared away – let us know if you have any questions or run into anything else!