Local Community

Uh-0h! Unable to provision site

Hey @Tim.Gangl – It’s hard to say what’s going on from the screenshot.

Can you please provide your Local Log? See this Community Forum post for instructions on how to do so:

I think I got it figured out. Avast put mysql to sleep. seems fine now. thanks

:shaking_fist: Antivirus!!!

I’ve never heard of that specific thing happening, but I could see how it would cause issues for Local.

Thanks for sharing what the underlying problem was with the community!

I’m having the same issue, and am new to ALL of this. This might me a dumb question, but can you tell me how to check if my antivirus put my sql to sleep. This was working fine the first day I installed it, and then then next day I started getting he same error messages. I’ve tired uninstalling and reinstalling, but it no longer works for me.

I’m not entirely sure how @Tim.Gangl verified that Avast was putting MySQL to sleep.

One thing you can try is temporarily disabling any antivirus software you have installed and see if that helps with this. You might also be able to open up the settings for your antivirus and see if it is blocking things that Local needs, for example MySQL.

Can you also please provide your Local Log so we can see if there’s more info contained within it? See this Community Forum post for instructions on how to do so:

was actually the cleanup not the antivirus it puts programs to sleep and cleans registries and things like that. Still super anoying.

I just tried to disable the AniVirus but it’s still not working.
Here is the error message:

{"thread":"main","class":"Process","process":"mysql","level":"warn","message":"2020-09-24T03:43:26.872683Z 0 [System] [MY-010931] [Server] %%resourcesPath%%\\lightning-services\\mysql-8.0.16+5\\bin\\win64\\bin\\mysqld.exe: ready for connections. Version: '8.0.16'  socket: ''  port: 10006  MySQL Community Server - GPL.","timestamp":"2020-09-24T03:43:26.873Z"}
{"thread":"main","class":"HostsFileService","stdout":"Updating hosts file at  C:\\WINDOWS\\System32\\drivers\\etc\\hosts\nUpdated hosts file at  C:\\WINDOWS\\System32\\drivers\\etc\\hosts\n","stderr":"","level":"info","message":"Updated hosts.","timestamp":"2020-09-24T03:43:29.026Z"}
{"thread":"main","service":{},"serviceBinVersion":{},"stack":"Error: Command failed: %%resourcesPath%%\\lightning-services\\mysql-8.0.16+5\\bin\\win64\\bin\\mysqladmin.exe --password= ping\nmysqladmin: [Warning] Using a password on the command line interface can be insecure.\r\n\u0007mysqladmin: connect to server at '::1' failed\r\nerror: 'Can't connect to MySQL server on '::1' (10013)'\r\nCheck that mysqld is running on ::1 and that the port is 10006.\r\nYou can check this by doing 'telnet ::1 10006'\r\n\n    at ChildProcess.exithandler (child_process.js:308:12)\n    at ChildProcess.emit (events.js:203:13)\n    at ChildProcess.EventEmitter.emit (domain.js:476:20)\n    at maybeClose (internal/child_process.js:1021:16)\n    at Process.ChildProcess._handle.onexit (internal/child_process.js:283:5)","level":"error","message":"Database did NOT respond to ping after 15 tries.","timestamp":"2020-09-24T03:43:35.831Z"}
{"thread":"main","class":"o","message":"Stopping ngrok for demo.local","level":"info","timestamp":"2020-09-24T03:43:35.835Z"}
{"thread":"main","class":"Process","process":"mailhog","pid":11676,"level":"info","message":"Killing process","timestamp":"2020-09-24T03:43:35.837Z"}
{"thread":"main","class":"Process","process":"phpCgi","pid":5052,"level":"info","message":"Killing process","timestamp":"2020-09-24T03:43:35.878Z"}
{"thread":"main","class":"Process","process":"phpCgi","pid":15088,"level":"info","message":"Killing process","timestamp":"2020-09-24T03:43:35.912Z"}
{"thread":"main","class":"Process","process":"nginx","pid":15636,"level":"info","message":"Killing process","timestamp":"2020-09-24T03:43:35.933Z"}
{"thread":"main","class":"Process","process":"mysql","pid":4788,"level":"info","message":"Killing process","timestamp":"2020-09-24T03:43:35.953Z"}
{"thread":"main","class":"","stack":"Error: Command failed: %%resourcesPath%%\\lightning-services\\mysql-8.0.16+5\\bin\\win64\\bin\\mysqladmin.exe --password= ping\nmysqladmin: [Warning] Using a password on the command line interface can be insecure.\r\n\u0007mysqladmin: connect to server at '::1' failed\r\nerror: 'Can't connect to MySQL server on '::1' (10013)'\r\nCheck that mysqld is running on ::1 and that the port is 10006.\r\nYou can check this by doing 'telnet ::1 10006'\r\n\n    at ChildProcess.exithandler (child_process.js:308:12)\n    at ChildProcess.emit (events.js:203:13)\n    at ChildProcess.EventEmitter.emit (domain.js:476:20)\n    at maybeClose (internal/child_process.js:1021:16)\n    at Process.ChildProcess._handle.onexit (internal/child_process.js:283:5)","level":"error","message":"Unable to provision site.","timestamp":"2020-09-24T03:43:35.974Z"}
{"thread":"main","reason":{},"p":{},"level":"warn","message":"Unhandled Rejection.","timestamp":"2020-09-24T03:43:49.692Z"}
{"thread":"main","reason":{"killed":false,"code":1,"signal":null,"cmd":"%%resourcesPath%%\\lightning-services\\mysql-8.0.16+5\\bin\\win64\\bin\\mysqladmin.exe --password= ping"},"p":{},"level":"warn","message":"Unhandled Rejection.","timestamp":"2020-09-24T03:43:49.695Z"}
{"thread":"main","class":"","message":"Deleting %%userDataPath%%\\run\\vu1D4OhZO","level":"info","timestamp":"2020-09-24T03:43:49.710Z"}
{"thread":"main","reason":{},"p":{},"level":"warn","message":"Unhandled Rejection.","timestamp":"2020-09-24T03:43:49.800Z"}
{"thread":"main","class":"HostsFileService","level":"info","message":"Updating hosts with","timestamp":"2020-09-24T03:43:50.568Z"}
{"thread":"main","class":"HostsFileService","stdout":"Updating hosts file at  C:\\WINDOWS\\System32\\drivers\\etc\\hosts\nUpdated hosts file at  C:\\WINDOWS\\System32\\drivers\\etc\\hosts\n","stderr":"","level":"info","message":"Updated hosts.","timestamp":"2020-09-24T03:43:53.456Z"}

Hey @yinjin, Welcome to the Local Community Forums!

I’m not seeing anything obviously wrong in those logs lines (except that mysqldump isn’t working).

When you disabled the antivirus software, did you try stopping the site and re-starting it?
What about creating a new site in Local, is that new, plain site created successfully and is accessible from the browser?

Bonjour,
J’ai le même problème, lors de la création d’un site.
L’erreur ci-dessous s’affiche dans une fenêtre Popup.
Impossible de provisionner le site
Je vous joins également le fichier local-lightning.log
local-lightning.log (35.9 KB)

Summary

This text will be hidden

Summary

This text will be hidden