Local Community

Unable to select Git Bash as Terminal

I’m on Windows 10, with Local Lightning 5.6.8. I also have git bash installed, but unable to select Git Bash as terminal. I’d rather not uninstall local and git bash and reinstall both…is there any other way I could troubleshoot / workaround?

Thank you!

Same issue for me. Windows 10, Local Lightning 5.6.8. I presume it’s a bug?

That’s definitely odd and something that we want to zero in on more!

Can you please provide your Local Log? See this Community Forum post for instructions on how to do so:

Hi Ben,

Here’s my log file.

local-lightning.log (809.7 KB)

Hope this helps.

I’m not seeing anything obvious in the local log that would be preventing that setting from working.

Are you able to record a screencast of what you are seeing so that I can get a better idea of what is happening?

Quite simply, in the settings under Default Apps, the Terminal dropdown is set to Command Prompt (Cmd) by default, and when I click on the dropdown arrow so I can choose a different terminal, the other option is Git Bash but that option is greyed-out and unclickable. It’s a visible option but not a selectable option. When I click on the Git Bash option nothing happens, and my assumption is that it could have something to do with Local being installed for all users on my machine, but Git Bash only being installed for a single user and perhaps not available for the Local install. Just a hunch, not sure.