Local Community

WP-CLI "search-replace" error on WP Engine site pull

Issue Summary

WP-CLI generates errors when performing the search-replace command to modify references to the site URL. Could it be because Local and my sites are on two different directories? I attempted to run search-replace myself but WP-CLI doesn’t recognize the directory as a WordPress install.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    Only one.

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?
    Yes

Replication

Pull site from WP Engine into Local

System Details

  • Which version of Local is being used?
    5.9.3+5100

  • What Operating System (OS) and OS version are being used?

    • Windows 10 Professional
  • Attach the Local Log. See this Community Forum post for instructions on how to do so:

    • {“thread”:“main”,“class”:“r”,“stack”:“Error: Command failed: “%%resourcesPath%%\lightning-services\php-7.3.5+10\bin\win64\php.exe” “%%resourcesPath%%\bin\wp-cli\wp-cli.phar” --path=“D:\local\jeremy-hixon\app\public” --require=”%%resourcesPath%%\bin\wp-cli\local-wpcli-error-reporting.php" --skip-plugins --skip-themes --url=jhixondvlp.wpengine.com “search-replace” --all-tables-with-prefix “http://jhixondvlp.wpengine.com” “http://jeremy-hixon.local”\n\n at ChildProcess.exithandler (child_process.js:304:12)\n at ChildProcess.emit (events.js:223:5)\n at ChildProcess.EventEmitter.emit (domain.js:475:20)\n at maybeClose (internal/child_process.js:1021:16)\n at Process.ChildProcess._handle.onexit (internal/child_process.js:283:5)",“level”:“warn”,“message”:“Unable to import site.”,“timestamp”:“2020-11-29T19:36:02.746Z”}

I am having the same issue. I did a standard install of Local today, which went to C, but I created Local Sites on my A: partition and set the path to that.

I get the same error above, but with the addition of Error: required file ‘local-wpcli-local-error-reporting.php’ doesnt exist (from runtime argument).

Any guidance? Thanks

I get the same error when pulling sites from WPEngine into drive D:/

When I tried to set the directory into default, which is in drive C:/, pulling works just fine.
Kinda kills the purpose being able to set where to pull WPEngine sites into if it can only be done in drive C:/

I don’t want these sites on my SSD, having too many sites will surely shorten the lifespan of my SSD.