Local Community

Local 5.2.3 Mac can't open MacOS Open/Save dialogs

I’ve uninstalled previous version (also VirtualBox), downloaded latest versions and Local 5.2.3 can’t open Open/Save dialogs (i.e. to choose where to store a site or save an export, or on the Preferences you can’t select a Default Sites Location. I’ll try downloading 5.2.1 and check if it works, or keep downgrading until it works.

Got solved on 5.2.4 but all the other failures of 5.x are core-based.

5.2.7 brought back the not opening Open/Save dialogs on MacOS Mojave.

Hey @fabiofava,

This might be related to the version of Electron we’re using. I’ll make a note for the team to look into this.

Hello @clay thank you for your reply.

The most concerning issues are, in this order:

  1. By this time it’s impossible for me to run Local Sites with HTTPS: Local Domains just plain doesn’t work, while localhost is the worse possible solution.

  2. Without Apache, it’s worthless since most hostings still use it. I’m not talking about Apache + Nginx (wich would be a dream but I know how hard is to make it to work), just Apache OR Nginx as it used to be.

Thank you for keeping alive the interest on your users. Cheers!

1 Like
  1. Makes sense! Do you know if you have any other web servers running locally? If so, if you temporarily turn off those web servers (essentially any processes on port 80 and/or 443), Local should work in the Site Domains mode.

  2. Apache was just released in Local Beta 5.5.0 (viewing this post requires that you’re part of the beta group) and should be hitting stable in the coming weeks :slight_smile:

Hey @clay thanks again for your reply!

  1. No other web server. I truly rely on your software.
  2. I’m downloading to test. Will Local Domains work?

Yup, they should as long as you don’t have any other local web servers running.

One thing worth noting, if you are on Windows, sometimes other hidden Windows features like IIS or even VMWare Workstation can cause port conflicts on ports 80 and 443.

Hey @clay thanks again for your prompt reply.

I use Mac OS Mojave and I have no other Apache service running, but if you tell me commands I can kill proccesses on the Mac OS so it may work. But a working version of Local should kill these proccesses by itself, doesn’t?

Cheers! I believe! Let’s make it work!

:man_facepalming:, sorry I should’ve realized that you were using macOS based on the thread title!


On that note, if you open up Terminal and run sudo lsof -i :80 | grep LISTEN, it should show processes on port 80.

I’ve just installed, but still can’t use Local Domains. As localhost doesn’t use HTTPS and not even a domain, it’s pretty much useless for any WordPress site development. It may work for plugin developers (wich I also question). The site should be accesible as it was on Local by Flywheel…

Here’s what I got:

httpd 111 root 4u IPv6 0x45712472d24b8bd9 0t0 TCP *:http (LISTEN)
httpd 534 _www 4u IPv6 0x45712472d24b8bd9 0t0 TCP *:http (LISTEN)

Aren’t those from Local Beta?

Best way to check is with Local off. Then if something exists it’s not from Local.

It looks like those might be the built-in Apache web server that ships with macOS.

If so, the following command should disable it:

sudo launchctl unload -w /System/Library/LaunchDaemons/org.apache.httpd.plist

(credit https://tosbourn.com/turn-off-the-built-in-apache-on-osx/)

Hey folks,

After unloading MacOS HTTPD, Local beta 5.5.0 is working. But now, instead of loading the site, it just shows a 502 error screen:

Anyway I assume that Local should run the HTTPD Unload command for the user. A message with a button to allow it would suffice, I assume.

It stills tries to load the site with a “?cache-buster=1877” appended to the URL, but if I remove it and add https:// it just works. With Apache.

  • MailHog stills load from localhost for some reason, instead of using the site URL.

  • Sequel Pro can’t access the DB and launches with an error as it had an error last session, even when it didn’t.

  • The Trust / SSL setting isn’t saving, so every time the site starts, have to Trust again. As I use Firefox it uses its own trust system, so the error may be on SSL.

I’ll keep looking forward for a fully working version (to finally retire Local by Flywheel 3.x and start enjoying a faster, non-VBox Local app.

Hey @clay,

I’ve just downloaded and I’m now testing Local 5.5.1 and… (drumrolls)

It seems like you’ve reached the Holly Graal buddy! I’m so happy!

Some bugs may arise, but I’m now ready to get rid of 3.x and VBox.

Confidently yours, @fabiofava

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.